System incident: Delays in flow
Minor incident
Management Interface
2025-11-24 15:19 CET
· 19 hours, 35 minutes
Updates
Resolved
November 25, 2025 · 10:53 CET
The incident in PlentyONE Flow has been successfully resolved. All functions should work normally again.
Issue
November 24, 2025 · 16:15 CET
An unexpected incident is currently affecting the functionality of PlentyONE Flow.
There are currently delays in the execution of PlentyONE Flow.
We are investigating the issue.
← Back
PlentyONE Status